Multi-Resolution Game Development With GameBuilder Studio Check it out!
NEW Version 0.9.7 has arrived! New Blazing Fast Particle Engine & More Game Actions. Check it out
Fixing The Blank Game Player On Windows
  • If you have downloaded GameBuilder Studio for Windows and launched a game you have run into this issue of a blank screen. The blank screen is due to a global flash security setting that disables all local flash content that is compiled with internet access enabled. Below is the solution to enabling all GameBuilder Studio games on your machine.

    Opening the Global Flash Player Settings Manager

    image

    The previous settings manager located at http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager04.html is no longer the location for this setting. You have to right click on the flash window and click on the "Global Settings" option to open the local Global Flash Settings Manager.

    Open Trusted Location Settings

    image

    Once the settings manager is opened change to the "Advanced" tab and open the "Trusted Location Settings" this is where you will set the trusted folder on your machine.

    Add The Root Folder Of Your GBS Projects

    image

    It is recommended to add the the root folder of whichever directory you will be saving GameBuilder Studio projects.

    **Note: Adding your whole drive could be a security risk if there are any malicious SWF files on your computer.

    This will enable all swf files in sub directories to access the internet without any security restrictions. This is needed for any plugins and components in GameBuilder Studio to make server calls while your game is running. Once you have done this close the settings manager and re-build your game in GameBuilder Studio. You should see the actual game instead of a blank white screen.

    If you still see a blank flash player most likely you do not have a supported graphics card to run GameBuilder Studio games. All games use the graphics card now to render the games to screen. You can test your graphics card by visiting http://helpx.adobe.com/x-productkb/multi/stage3d-unsupported-chipsets-drivers-flash.html and scrolling down to the bottom. If the window at the bottom of the page says your graphics card is supported and you still see a blank screen then please contact us at support@gamebuilderstudio.com so we can asses your machine setup.

    **LAST RESORT SOLUTION

    This will have to do until we implement a solution.

    Find the build.xml file in the GBS compiler folder on your machine it should be located in C:\Users\[CURRENT USER]\AppData\Roaming\GameBuilderStudio\Local Store\compiler\Shared\bin\build.xml

    Replace "-use-network=${USE_NETWORK}" with "-use-network=false" then launch/compile your game again in GBS. Not a quick launch. This will not allow you to run any plugins that require internet access to make server calls but you will at least be able to run the game for now until there is a fix.

    Screen_shot_2013-02-20_at_11.25.17_AM.png
    540 x 352 - 48K
    Screen_shot_2013-02-20_at_11.25.30_AM.png
    540 x 387 - 85K
    Screen_shot_2013-02-20_at_11.25.59_AM.png
    540 x 428 - 111K
  • 2 Comments sorted by
  • This also happened to me on a Mac. To find the directory I opened a new example project and ran it and the location of the SWF was, "/Users/me/Library/Preferences/GameBuilderStudio/...". I had to add this directory to the the preferences panel. However, the Flash Player preferences panel won't let you add hidden folders so I selected a random folder and then it let me edit the location and paste in the path to the hidden folder.

    I also found I could save the project to the "documents/GameBuilderStudio" directory and add the exception for it there.
  • I was going to add the last part @Judah:

    "I also found I could save the project to the "documents/GameBuilderStudio" directory and add the exception for it there."

    but you got it covered. Thanks for posting!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Tagged