Multi-Resolution Game Development With GameBuilder Studio Check it out!
NEW Version 0.9.7 has arrived! New Blazing Fast Particle Engine & More Game Actions. Check it out
I have a compile ERROR when launching a game.
  • Hello i am trying to make my game and when launching the game i get an ERROR:Compilegame-Failed-Compiling game process failed, the generated swf can not be found, I need help!
  • 16 Comments sorted by
  • @Mitchell this compile error can be caused by a number of things. You can always see what the compile error is by opening the hidden console window by hitting the "~" (tilde key) on your keyboard. If you double click the black screen that opens up it will copy the complete error message to your clipboard.

    A compile error can be caused because of Java not being installed first if you are on a mac. The version of Java that needs to be installed is provided right above the download link on your GBS dashboard.

    Another reason could be that you added a resource to your project and did not save your project first. The best way to diagnose the compile error is to see what the console says.

    Also keep in mind that GameBuilder Studio compiles both hand written code and any visual changes you make to your game in-editor. So if you added any custom code to the underlying game project in the bin folder, that has an error in it, the error message will also appear in the console window.
  • Its telling me something about SWF?
  • @Mitchell Can you double click the console and paste the error message into a file and send over?

  • Please help! Also on my computer it's a problem when want run a game. Compile error. Compile game failed, the generated SWF can not be found!

    HELP! 
  • Hi @Taras
    Can you please open the Console in the editor and double click on the text and paste it here? There should be an error message.
  • ok my mistake! Problem was with missing files. Everything works now! Thanks :)
  • @Taras, great! Would love to see what you create with the tool when you are finished :)
  • I open the Demo project PlatformGame and when compile have the same Error. My OS Ver. Windows 8.1 Professional.

    Message from Console: 

    LoaderManager - registerLocalResource - A resource from file missing_graphic.png has already been registered.

    CompileGameCommand - CompileGame - FAILED - Compiling Game Process Failed, The generated swf can not be found.
  • Hi @Vadim, please submit a ticket here: http://gamebuilder.zendesk.com/tickets/new with the complete output of the console by double clicking inside the console window to copy the text to the clipboard.
  • Hi Lavon,

    When I try to make a new ticket http://gamebuilder.zendesk.com/tickets/new the page is refresh and forwarding here http://gamebuilderstudio.com/beta/dashboard
  • @Vadim, do you have a space in the project file name? That may be the issue. GameBuilder Studio doesn't like spaces. The name of the project is used to generate the class name of the final game swf.
  • I find the problem,

    In Windows has path to User folder C:\Users\{User name}. My {User name} was write in Cyrillic letters. When I compile the Demo project it has an Error with strange symbols. I found the video how to rename User folder from Cyrillic to Latin letters: https://www.youtube.com/watch?v=jwl4YJlAx-A then I also had to find all the places in the registry (regedit command) where used the old {User name} and replace it with new one, in order to all other installed software runs correctly.

    After that all Demo project works correctly, and now I learn Hungry Hero Tutorial, and say that the GameBuilder Studio is so intuitive and easy to use, I like it.
  • @Vadim ok great! Thanks for sharing this.
  • Same problem.

    Message from console:


    CompileGameCommand - Compile Game Process |      [java] Error: Unable to resolve root class of SWF: game
    CompileGameCommand -      [java] 
    CompileGameCommand -      [java] Error: Unable to build SWF C:\Users\username\Documents\game\build\game.swf
    CompileGameCommand - 
    CompileGameCommand - Compile Game Process |      [java] 
    CompileGameCommand - 
    CompileGameCommand - CompileGame - FAILED - Compiling Game Process Failed, The generated swf can not be found.

  • Never mind. The problem was that I had a space in my project name

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion