Multi-Resolution Game Development With GameBuilder Studio Check it out!
NEW Version 0.9.7 has arrived! New Blazing Fast Particle Engine & More Game Actions. Check it out
How do I fix the Context3D Wmode Error?
  • I was in an example demo, I lunched it, and the characters are replaced with squares. The text said the cause might be either a problem with the wmode or a missing support file needed to be added. Got any ideas?
  • 3 Comments sorted by
  • Hi @johnson what OS are you using? Have you tested your graphics card at this link (test card)? Is it possible for you to send a screen shot of the error?
  • Well, to be honest. I don't know how to check my OS. And the graphic test said this:

    Your gpu does not supports Stage3D in Baseline or Constrained profile.
    Baseline RenderMode: 
    Software Hw_disabled=unavailable
    Constrained RenderMode: 
    Software Hw_disabled=unavailable (Baseline Constrained)

    So I went on to this site:


    And I found out my java was out dated. I thought that was the problem, but it turned out it's not. I lunched GameBuider Studio, then checked the platformer demo, lunched it, and you know, the problem still exist. The error was:

    Context3D not available! Possible reasons: wrong wmode or missing device support.

    So after I went back to the link you recommended. Went to this site:


    It asked what's my OS, and of course I have no clue. I looked at the side, an auto OS checker/Graphic Card installer. I downloaded it and it told me it was "Unable to find my OS" and after the installer brings up a window to let me pick a graphic card to install. But there's no graphic card I can choose from, cause it's blank. So I went back the link you recommended, then went onto this site:


    It asked me what's my product and system I'm using. I skipped it and went straight on to the automatically find my driver button. They have no clue. So I'm guessing it's either I don't have a graphic card or my computer security is really over protective. As for the screen shot, how do I do that? So do you have any idea to help me? Thanks.
  • Hi @johnson,

    Unfortunately, based on the output of that graphics card test, your system doesn't meet the system requirements to run GBS. Your graphics card has to support Stage3D to view launched games from the editor. There is an option in the Publish settings window to switch default rendering mode from GPU to CPU (standard flash display list) but this is a PRO feature only. The reason GBs games default to GPU rendering mode is because it allows your games to run at the highest performance especially on mobile devices.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion

Tagged