Multi-Resolution Game Development With GameBuilder Studio Check it out!
NEW Version 0.9.7 has arrived! New Blazing Fast Particle Engine & More Game Actions. Check it out
OS X Handshake Error "Always Use The Latest Build"
  • Hi,

    I'm trying to install GBs ( Version - 0.9.8_Build-699 - FREE from the downloads page) on Mac OS X 10.11.3
    I've downloaded the Java file and tested my graphics card (flash file eventually turned up, I think, I got a menu box...)
    I've run the installer and it told me I needed a newer version.
    Air updated a newer version and then for the first five times when I tried to run the app it was "Not Responding but was asking me for keychain access (which I granted). 
    I quit it for a bit and waited (it seems to hang around in the background a while after quitting) then launched the app again and it finally accepted my keychain access and moved on to the licence validation screen. I pasted my validation code in and it spat out an error message:

    The message was about a Handshake error and it said "Always use the current version" which I assumed I had, until it updated, which I assume means I have the latest version now?

    I accidentally lost the copied error message, so I tried to recreate it by launching the app again. Now it stops responding on the keychain message again.

    Can anyone help with this?

    I can get an error report that Apple gets and paste it here if that helps.

    • Problem 1: How do I ensure I have the latest build
    • Problem 2: How can I stop the app from 'not responding'.


  • 3 Comments sorted by
  • Hi, @nhf 

    Try deleting the entire GBs storage folder on your computer located in /Users/[USERNAME]/Library/Application\ Support/GameBuilderStudio/

    This will cause a fresh install to take place when you run GBs again.








  • GBs will respond if I deny the keychain request.

    -------------------------------------------------

    "GameBuilderStudio wants to use your confidential information stored in "Adobe.APS" in your Keychain.

    The authenticity of "GameBuilderStudio" cannot be verified. Do you want to allow access to this time?
    Always Allow / Deny / Allow

    -------------------------------------------------

    Always allow does nothing.
    Allow does nothing.
    Deny gives me the following, unhelpful error message.


    ERROR - There was an error initializing the application. Error Message = [EncryptedLocalStore internal error] Stack Trace = [Error: EncryptedLocalStore internal error
    at flash.data::EncryptedLocalStore$/processErrorCode()
    at flash.data::EncryptedLocalStore$/getItem()
    at GBSAppPM/getStoredByteArrayFromES()
    at GBSAppPM/initApp()
    at GameBuilderStudio/set _104069929model()
    at GameBuilderStudio/set model()
    at com.asfusion.mate.core::Binder/bind()
    at com.asfusion.mate.actions::PropertyInjector/run()
    at com.asfusion.mate.actions::AbstractAction/trigger()
    at com.asfusion.mate.actionLists::AbstractHandlers/runSequence()
    at com.asfusion.mate.actionLists::Injectors/fireEvent()
    at flash.events::EventDispatcher/dispatchEventFunction()
    at flash.events::EventDispatcher/dispatchEvent()
    at mx.core::UIComponent/dispatchEvent()
    at com.asfusion.mate.core::GlobalDispatcher/dispatchEvent()
    at com.asfusion.mate.core::ListenerProxy/listenerProxyHandler()
    at flash.events::EventDispatcher/dispatchEventFunction()
    at flash.events::EventDispatcher/dispatchEvent()
    at mx.core::UIComponent/dispatchEvent()
    at mx.core::UIComponent/set initialized()
    at mx.managers::LayoutManager/doPhasedInstantiation()
    at mx.managers::LayoutManager/doPhasedInstantiationCallback()]
  • Hi Lavon, thanks for getting in touch.

    That fixed it, I'm in now! 

    Thank you very much,

    Matt.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion