Multi-Resolution Game Development With GameBuilder Studio Check it out!
NEW Version 0.9.7 has arrived! New Blazing Fast Particle Engine & More Game Actions. Check it out
v9.7 Release Candidate 522 Bugs Feedback
  • So far in quick testing these are the following issues I've found

    when changing levels if you don't use force unload, my next level sprite frame animation isn't compiled into one single image leaving me with 6 entities on top of each other when running the game.

    Force unload is still an issue on one of my levels, but now I'm thinking its actually something I'm going. On all of my other levels and games it seems to work fine.

    I'll keep updating as I work
  • 22 Comments sorted by
  • I was using 9.5 503 before updating to 9.7 RC 519 and then 9.7 522.
    While running 9.5 503 All my buttons have a trigger action to Change Level with force unload checked and everything worked fine.

    With both the 9.7 versions I haven't changed anything in the game and when any buttons are clicked or tapped, the screen goes to the background color(selected in the Publish window project tab) and never shows the level the button is set to navigate to i.e. Main Menu, Play, Play Again, Settings.

  • @Carlton, @BenFromOregon I believe this issue has been covered in a fix coming in the next release candidate that should be out by tomorrow.
  • @Lavon, There is also an issue with reordering in the layers menu along with reorder actions in the rules component.
  • @Carlton yes thats been addressed as well in the new build (523)
  • @Lavon version 523 won't compile any existing projects.
  • @Carlton  Everything works with 523 so far for me. Are you on a Mac?
  • @Carlton what is the error message in the console. (double click in the console to copy to clipboard) I need a bit more information to figure out why its failing.

    @BenFromOregon, you shouldn't need to do that. GBs wipes out that folder during the upgrade process. Do you see a compile error every time you upgrade?
  • @Lavon I was having to do this every time yes. I can try and reinstall 9.5 and get back to the latest build with just clicking replace and see what happens, I'll post here is a short while.
  • @Lavon  Alright, I reinstalled a 9.5 version then back to the latest build of 9.7 by clicking Replace in the Application Install Widow within the build file and now it works. No compile errors.
  • @Lavon I converted back to 522 I'm going to do some work and then make a back up and try 523 later on again tonight, it might have been something I did.

    I had a storage component that I removed soon as I started it and I try to reposition one of my layers.

    I'll report back later
  • @Lavon everything seems to be working fine now, I am on a mac. I'll keep you posted.
  • When forcing a level reload of the same level animations stop. The level will reload fine, but all sprite animations stop.
  • @Carlton do your animations auto start playing when the game loads initially?
  • @Lavon, yes everything runs initially.

    I'm also having an issue deploying to none retina devices for iOS only. 
    I don't' receive any errors but the splash screen comes up and then it stays there for 10 seconds and then the application closes. I haven't rolled back to see if this was a version issue, but it was working before I tested 523.

    Thank you,
  • @Carlton, not sure why you are seeing these errors. Can you zip up your project and send it in so we can debug? I assure you your asset won't be shared or used.
  • @Lavon, I'll zip it up and send it over to you this afternoon as it was when it wasn't working on standard ios devices. Like I said it works well on retina devices and android devices, but not the standard ios.

    I thought that it might be a problem with my local storage load. disabled it. nope
    I thought maybe its my re-positioning to screen size logic. disabled it. nope

    When I try to run the application the splash screen opens up, the background track starts to play. I hear the witch laugh audio that I have playing when the level is loaded, and half way through the witch laugh it crashes, without every displaying the level on the screen.

  • @Lavon, I'm unable to attach my project. It won't let me attach a project that is bigger than 1mb
  • @Carlton please upload the file to dropbox and email the link.
  • @Carlton also what version of iOS are you running on the non retina iOS device?
  • @Carlton the animations stopping on level force reload has been fixed. Still looking into the non-retina iPad issue...
  • @Carlton your iPad game issue is definitely a lack of resource optimization. You have eaten up quite a bit of image memory and the app just crashes on load.

    Couple Optimization tips:

    - Remove all unused assets from your project (there are a lot currently that are not being used)
    - Utilize sprite sheets and pack all of your assets into a sprite sheet. Currently you have a really high draw count which is a result of using individual images for everything. A sprite sheet will allow you to compact your images into one image and reduces draw calls.

    When I stripped down your project I was able to get it running on an older non-retina iPad. There will be even more optimizations and compression features built into GBs in the next two releases which will help as well.
  • @Lavon, Thanks so much I forgot the basics.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion