Multi-Resolution Game Development With GameBuilder Studio Check it out!
NEW Version 0.9.7 has arrived! New Blazing Fast Particle Engine & More Game Actions. Check it out
Spine objects don't render
  • Hi Lavon. I've spent the whole afternoon trying to add a new spine object (mesh deform) to my old test project. Everything worked fine two weeks ago, I added several spine mesh animations, wich worked great but today the new objects just don't show. The skel, .json and .png are there and show in the "assets" tab correctly but once on the stage, when I run the game there are no spine objects. I've created several objects and still, no luck. I know there's a bug when changin levels with spine textures not loading, but there are no levels in my test project aside level_0. Do you have any clue what can be happening?
  • 9 Comments sorted by
  • @kikubu I need more information. What version of Spine are you using? Keep in mind that Spine updates their editor and breaks the runtimes before actually updating the officially supported runtimes so don't use the very latest. The currently supported runtime is up to version 2.10 I believe.

    If you want to send in a link to your zipped up project that is not rendering please do. Spine rendering seems to be working fine.
  • Lavon, I've tried exporting with Spine version 1.9.10 (The last supported as stated in the console) and it gives me an error, saying that GBS only supports spine's .json up to version 1.9.10, wich has no sense since that's the version I'm exporting with.
    If I export with versions 2.x there are no errors and I can import assets into GBS, even I can see the animations when I launch the Flash player if using CPU instead GPU. If I select GPU, there's no spine entities on the screen.
    I'm into this loop, where I can no longer use spine mesh animations, but I could a couple weeks ago.

    I send you a file, hope you can check it out. In that file, there's an entity called "NewObject_0" on Level 0 that doesn't render, but if you switch to CPU rendering, you can see the mesh moving, weird.

  • @kikubu please send a zip file.
  • @kikubu thanks for sending in your project it help to catch the bug. It was a really weird rendering bug. It is addressed in the build coming out. (Build 539/540)

    Next time if you want to send the link privately use the contact link on the main site.
  • thank you for your help, I'm very grateful, and sorry for bothering you, but I was going mad :).
    yep, I didn't realised I was posting for everyone! how domb can I be, I'm deleting it right now
  • @kikubu no worries. Please don't hesitate to post any issues you run into. I try to address everything as soon as possible.
  • All working fine, just don't use "trim" in texturepacker. Also I've tested with Spine 2.17 and is working!!!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion