Multi-Resolution Game Development With GameBuilder Studio Check it out!
NEW Version 0.9.7 has arrived! New Blazing Fast Particle Engine & More Game Actions. Check it out
Bugs v0.9.7.-535 Timer FoundEntity
  • I updated from v0.9.7.-531 to v0.9.7.-535, have two bugs so far:

    - Timer action isn't working at all
    - data can't be red out of a FoundEntity / FoundSpatial, I tried to read the spatial.x and data from a DataContainer on that entity without success
  • 13 Comments sorted by
  • @Cavaron I don't think this is a bug, are you executing a Found Object In Range action then using a nested Timer to trigger another action?

    If so this will not work well because the CurrentActionData property is dynamic and only available the first time the nested action is executed. If you use a Timer action that continuously runs in the background by the time it executes again the property has been changed or removed. Make sense.
  • @Lavon I think I earned my lesson about action timing... at least I hope so ;)
    The timer is inside a RulesMap checking for Game_Running state. It worked bevore I upgraded to build 535 - maybe it's an upgrade-related problem?

    But I used a Found Object In Range action with a nested change property reference for the found entitys spatial.x to write into a DataContainer. Didn't work in both versions.
  • @Cavaron are you saying the Timer action does not trigger at all? and the Find Object In Range is not populating the CurrentActionData property even though their is an object in range?

    If so please send in a link to your project zipped up so we can take a look at it and debug.
  • @Lavon please see support Request #1218 for further details. The Find Object In Range action problem could be solved (indeed, a to short search distance was choosen... at first, I even thought the distance got added to the spatial/collisian shape selected above - in fact it has to be it's size or more), my bad. Timer issue remained, an error #2005 with invisible spatials added on top of that.
  • @Cavaron ok I will have it debugged.
  • Today i upgraded GBs to build 536 and all object which i have in project and any of this objects don't spawn. Anybody have the same problem?
  • If you wanted to say 535, then yes. 536 don't seem to be available yet. In one case, instead of spawning something, another object from screen got transportet to the spawning coordinates. Even the destroy-command doesn't work any more. But thats just in one of my two actual projects. The other one is fine with 535...

    Could have been part of the problem with my timere here, because he was supposed to spawn objects. Lavon said, there could be another build in the next day or two.
  • @Xman yes there is a new build on the way.
  • Lavon the new build 540 for Mac Os it cant be download.

    <Message>Access Denied</Message>
  • @Xman sorry about that. Try it again.
  • no problem :) Thank you

  • All works fine for now Thank you once again! ;)

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

In this Discussion